FAQ

BSOD mit Notebook & Dockingstation

Sie haben auf einem Notebook den NetSupport Manager CLIENT im Einsatz. Verwenden Sie das Notebook in Kombination mit einer Dockingstation, so kann es passieren, dass Sie einen BlueScreen (BSOD) auslösen.

Beschreibung

Sie haben auf einem Notebook den NetSupport Manager CLIENT im Einsatz.

Verwenden Sie das Notebook in Kombination mit einer Dockingstation, so kann es passieren, dass Sie einen BlueScreen (BSOD) auslösen.

Ursache

NetSupport Manager kann sprach-übergreifend eingesetzt werden.

Sie können den CONTROL z.B. auf einem Admin-PC in Deutschland verwenden, während der CLIENT auf einem Produktions-PC in China installiert ist.
In diesem Fall wird der CONTROL über eine deutsche Tastatur bedient, während der CLIENT es mit einem chinesischen Tastatur zu tun hat.
Ergänzend dazu könnte der CONTROL trotz deutscher Tastatur mit einem englischen Tastenlayout konfiguriert sein.

Um all die unterschiedlichen Kombinationen von Tastaturen und Tastenlayouts zwischen einem CONTROL PC und einem CLIENT PC handhaben zu können, verwendet NetSupport Manager einen Tastaturfiltertreiber. Solch ein Filtertreiber wird per Design sehr hardwarenah verwendet und ist in der Regel an einen bestimmten Treiber der zu überwachenden Hardware gebunden.

Wenn Sie nun ein Notebook in eine Dockingstation eindocken bzw. es wieder ausdocken, wechselt die aktive Tastatur vom Notebook zur Dockingstation bzw. wieder von der Dockingstation zum Notebook zurück.

Wird der Tastaturfiltertreiber über diesen Wechsel der zu überwachenden Tastatur nicht korrekt informiert, sie kann es sein, dass der Filtertreiber mit einer nun nicht mehr vorhandenen Hardware kommunizieren will. Dies führt in aller der Regel dann zu einem BlueScreen (BSOD)

Lösung

Ab NetSupport Manager Version 12.70.0004 wird eine Option zur Selektion des verwendeten Tastaturfiltertreibers angeboten.

Um auf diese Einstellung zuzugreifen, gehen Sie bitte wie folgt vor:

  • starten Sie den NetSupport Manager Configurator
  • wählen Sie die Konfigurationsoption Erweitert bzw. Advanced
  • öffnen Sie das betroffene Profil (im Regelfall das Master Profile) per Doppelklick
  • wählen Sie im linken Menü den Eintrag Erweitert bzw. Advanced
  • ändern Sie über das Pulldownmenü Tastaturfiltertreiber bzw. Keyboard Filter Driver die Einstellung

Hier können Sie den Treiber auf die Option Sekundär einstellen, um einen alternativen Treiber zu verwenden und somit das Problem zu vermeiden.

In der Client-Konfigurationsdatei client32.ini bzw. client32u.ini ändert sich hierdurch der Wert für den Eintrag KBFilterVer in der Sektion [General]

Hierbei haben die Werte folgende Bedeutung:

KBFilterVer=0 => Standard
KBFilterVer=1 => Primär
KBFilterVer=2 => Sekundär

Sollte der Eintrag KBFilterVer fehlen, so wurde die Option noch nie konfiguriert und es gilt die Default-Einstellung Standard

Hinweis

Findet der BSOD nur in Verbindung mit einer Dockingstation statt oder können andere Umstände zu dem BSOD führen?

Dieses Problem ist nur bekannt, wenn ein Notebook und eine Dockingstation in Kombination verwendet werden.
Das Problem tritt zufällig auf und wir können es nur dann reproduzieren, wenn wir das Notebook von der Dockingstation an- oder abdocken.
Uns ist nicht bekannt, dass dies bei der Durchführung anderer Schritte auftritt.

Macht es nur Sinn, diese Konfiguration in Kombination mit einer Dockingstation anzupassen, oder kann es auch helfen, diese Einstellung in anderen Situationen zu ändern?

Wir empfehlen, dies bei Geräten nur dann zu ändern, wenn eine Dockingstation verwendet wurde und das Problem aufgetreten ist.
Das Problem schient auch gerätespezifisch zu sein.
Bei bestimmten Dockingstation-Kits waren wir nicht in der Lage, den BSOD zu reproduzieren.
Es sollte also nicht unter allen Umständen erforderlich sein, die Einstellungen anzupassen.

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